aboutsummaryrefslogtreecommitdiff
path: root/libobjc/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-15 17:05:36 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-15 17:05:36 +0000
commitb5bed5a5917935f1ba0fae40dd8359d46b3d38fb (patch)
tree39ce7b01f6486eb3624203c9f807dfedcd092001 /libobjc/configure.ac
parent00bc210cc2172fe633b9dd3b4cafd103b7eb17f9 (diff)
PR libobjc/14948
* configure.ac: De-precious CC so multilibs work. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@80724 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libobjc/configure.ac')
-rw-r--r--libobjc/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/libobjc/configure.ac b/libobjc/configure.ac
index b0c86bd9282..e6d65fa5e83 100644
--- a/libobjc/configure.ac
+++ b/libobjc/configure.ac
@@ -159,7 +159,16 @@ AC_SUBST(toolexeclibdir)
# --------
GCC_NO_EXECUTABLES
+
+# We must force CC to /not/ be a precious variable; otherwise
+# the wrong, non-multilib-adjusted value will be used in multilibs.
+# As a side effect, we have to subst CFLAGS ourselves.
+m4_rename([_AC_ARG_VAR_PRECIOUS],[real_PRECIOUS])
+m4_define([_AC_ARG_VAR_PRECIOUS],[])
AC_PROG_CC
+m4_rename([real_PRECIOUS],[_AC_ARG_VAR_PRECIOUS])
+
+AC_SUBST(CFLAGS)
AC_CHECK_TOOL(AS, as)
AC_CHECK_TOOL(AR, ar)