aboutsummaryrefslogtreecommitdiff
path: root/libobjc/configure.ac
diff options
context:
space:
mode:
authorayers <ayers@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-24 21:57:22 +0000
committerayers <ayers@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-24 21:57:22 +0000
commite23e7a9155a79d326a25567faa2d6b870d5f3423 (patch)
tree85fe1b7ee2078b5f5f57e2e3ff58875538077a45 /libobjc/configure.ac
parent01473a49825d174b3e9a184e9da5c5ca009077e7 (diff)
2006-01-24 David Ayers <d.ayers@inode.at>
PR libobjc/13946 * configure.ac: Add include directives for --enable-objc-gc. * Makefile.in: Ditto. * configure: Regenerate. * gc.c (__objc_class_structure_encoding): Increment the used bytes instead of the local pointer to them. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@110182 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libobjc/configure.ac')
-rw-r--r--libobjc/configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/libobjc/configure.ac b/libobjc/configure.ac
index b1b43ad12e3..bc3eb2da070 100644
--- a/libobjc/configure.ac
+++ b/libobjc/configure.ac
@@ -1,6 +1,6 @@
# Process this file with autoconf to produce a configure script.
# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004
-# Free Software Foundation, Inc.
+# 2005, 2006 Free Software Foundation, Inc.
# Originally contributed by Dave Love (d.love@dl.ac.uk).
#
#This file is part of GCC.
@@ -73,11 +73,18 @@ AC_ARG_ENABLE(objc-gc,
[ --enable-objc-gc enable the use of Boehm's garbage collector with
the GNU Objective-C runtime.],
[case $enable_objc_gc in
- no) OBJC_BOEHM_GC='' ;;
- *) OBJC_BOEHM_GC=libobjc_gc.la ;;
+ no)
+ OBJC_BOEHM_GC=''
+ OBJC_BOEHM_GC_INCLUDES=''
+ ;;
+ *)
+ OBJC_BOEHM_GC=libobjc_gc.la
+ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
+ ;;
esac],
-[OBJC_BOEHM_GC=''])
+[OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''])
AC_SUBST(OBJC_BOEHM_GC)
+AC_SUBST(OBJC_BOEHM_GC_INCLUDES)
# -----------
# Directories