aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2015-02-25 01:30:13 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2015-02-25 01:30:13 +0000
commitb286a2c0415bf2cad332b7cb5c1cdd17a1d00b91 (patch)
tree0cf6df3885372a83a624677d9726b36649233a20 /CMakeLists.txt
parent02ab17eddb3f07abd0abcd8e357786a95de62d9a (diff)
Suppress 'warning C4062: enumerator X in switch of enum Y is not handled' from system header.
git-svn-id: https://llvm.org/svn/llvm-project/lld/trunk@230422 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 436a6f71e..9107aae99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,7 @@ endif()
if (MSVC)
add_definitions(-wd4530) # Suppress 'warning C4530: C++ exception handler used, but unwind semantics are not enabled.'
+ add_definitions(-wd4062) # Suppress 'warning C4062: enumerator X in switch of enum Y is not handled' from system header.
endif()
include_directories(BEFORE