aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2012-02-02 16:42:32 -0700
committerJohn Rigby <john.rigby@linaro.org>2012-05-21 00:23:20 -0600
commitdb7ec85605c2686f54fac054f697f9ed828935b1 (patch)
tree864f7262cc0571bb890ed2f18b894662344c19cc /debian
parent9e3b64ac66cea424699c20f15c3f1745878a7804 (diff)
LINARO: add ability to timestamp source package name in debian/changelog
Signed-off-by: John Rigby <john.rigby@linaro.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 061fbd4752d3..3102d28d6cb3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,8 @@
#
DEBIAN=$(shell awk -F= '($$1 == "DEBIAN") { print $$2 }' <debian/debian.env)
+TIMESTAMP:=$(shell printf %x $$(date +%s))
+_DUMMY:=$(shell sed -i -e '1 s/%TIMESTAMP%/$(TIMESTAMP)/' $(DEBIAN)/changelog)
# dpkg-buildpackage passes options that are incomptatible
# with the kernel build.
@@ -59,15 +61,12 @@ clean: debian/control
# This gets rid of the d-i packages in control
cp -f $(DEBIAN)/control.stub $(DEBIAN)/control
- cp -p $(DEBIAN)/changelog debian/changelog
+ cat $(DEBIAN)/changelog debian/changelog | \
+ sed -e '1 s/%TIMESTAMP%/$(TIMESTAMP)/' > debian/changelog
# Install the copyright information.
cp -p $(DEBIAN)/copyright debian/copyright
- touch -r $(DEBIAN)/control.stub.in $(DEBIAN)/control $(DEBIAN)/control.stub debian/control debian/control.stub
- touch -r $(DEBIAN)/d-i/kernel-versions.in $(DEBIAN)/d-i/kernel-versions
- touch -r $(DEBIAN)/changelog debian
-
distclean: clean
rm -rf $(DEBIAN)/control $(DEBIAN)/control.stub \
$(DEBIAN)/d-i/kernel-versions debian/changelog \