aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAbdellatif El Khlifi <abdellatif.elkhlifi@arm.com>2020-10-16 17:46:12 +0100
committerRui Miguel Silva <rui.silva@arm.com>2020-11-24 13:08:07 +0000
commitb4029e2ef591c9db1853f73cb8ef3a9a01114980 (patch)
tree23862176386ba7d437780c8ed811cf0919a63a8b
parent76abdc9ec13284a4490ec6d2170d9d9d3235de97 (diff)
arm-image/core: configuring the image for corstone500 machineHEADCORSTONE-700-2020.12.10CORSTONE-500-2020.11.27master
Defining rootfs content and enabling WIC mechanism for the corstone500 machine. Change-Id: Ia2806f17de543df4d0baa6697541308986193a07 Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
-rw-r--r--recipes-core/images/arm-reference-corstone500-image.inc20
-rw-r--r--recipes-core/images/arm-reference-image.bb1
-rw-r--r--wic/arm-reference-image.corstone500.wks16
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-core/images/arm-reference-corstone500-image.inc b/recipes-core/images/arm-reference-corstone500-image.inc
new file mode 100644
index 0000000..10ad699
--- /dev/null
+++ b/recipes-core/images/arm-reference-corstone500-image.inc
@@ -0,0 +1,20 @@
+inherit wic_nopt
+inherit u-bootimg
+inherit image-buildinfo
+
+IMAGE_FEATURES += "debug-tweaks"
+
+IMAGE_FSTYPES += "wic wic.nopt cpio.gz.u-bootimg"
+
+IMAGE_INSTALL += "packagegroup-core-boot"
+
+# deleting the /usr/lib/opkg/alternatives folder
+# because we do not need alternative commands to what
+# busybox offers. This saves around 1MB flash
+remove_alternative_files () {
+ rm -rf ${IMAGE_ROOTFS}/usr/lib/opkg
+}
+ROOTFS_POSTPROCESS_COMMAND += "remove_alternative_files;"
+
+#package management is not supported in corstone500
+IMAGE_FEATURES_remove = "package-management" \ No newline at end of file
diff --git a/recipes-core/images/arm-reference-image.bb b/recipes-core/images/arm-reference-image.bb
index 9e482a4..cc41956 100644
--- a/recipes-core/images/arm-reference-image.bb
+++ b/recipes-core/images/arm-reference-image.bb
@@ -6,5 +6,6 @@ inherit core-image
MACHINE_IMAGE_REQUIRE ?= ""
MACHINE_IMAGE_REQUIRE_corstone700 = "arm-reference-corstone700-image.inc"
+MACHINE_IMAGE_REQUIRE_corstone500 = "arm-reference-corstone500-image.inc"
require ${MACHINE_IMAGE_REQUIRE}
diff --git a/wic/arm-reference-image.corstone500.wks b/wic/arm-reference-image.corstone500.wks
new file mode 100644
index 0000000..42c3ce7
--- /dev/null
+++ b/wic/arm-reference-image.corstone500.wks
@@ -0,0 +1,16 @@
+# WIC partitioning for corstone500
+# Layout and maximum sizes:
+#
+# FIP image: 1 MB
+# Linux kernel: 12 MB
+# Ramdisk rootfs: dynamic size
+#
+
+# Rawcopy of the FIP binary
+part --source rawcopy --sourceparams="file=fip.bin-a5ds" --no-table --align 1 --fixed-size 1
+
+# Rawcopy of the kernel binary
+part --source rawcopy --sourceparams="file=zImage" --no-table --fixed-size 12
+
+# Rawcopy of the rootfs
+part --source rawcopy --sourceparams="file=${IMGDEPLOYDIR}/arm-reference-image-corstone500.cpio.gz.u-bootimg" --no-table \ No newline at end of file