summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorArthur She <arthur.she@linaro.org>2014-10-05 09:47:25 -0700
committerMilosz Wasilewski <milosz.wasilewski@linaro.org>2014-10-15 11:16:58 +0000
commit04d06939bf4501d870bc85b4883c9a8909bfb847 (patch)
treea5a7742629b871769c1b8ea7380514254beade22 /openembedded
parent162ae95f869984b1a5cc13fee402261d27913b90 (diff)
kselftest: Add in kernel selftests
Add cpu-hotplug, efivarfs, memory-hotplug, mqueue, net, ptrace, vm tests for both openembedded and ubuntu Change-Id: Ia0b77e6e287b66b07db295a6c9efcf56027cb969
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/kselftest-cpu-hotplug.yaml37
-rw-r--r--openembedded/kselftest-efivarfs.yaml39
-rw-r--r--openembedded/kselftest-memory-hotplug.yaml38
-rw-r--r--openembedded/kselftest-mqueue.yaml36
-rw-r--r--openembedded/kselftest-net.yaml33
-rw-r--r--openembedded/kselftest-ptrace.yaml34
-rw-r--r--openembedded/kselftest-vm.yaml38
7 files changed, 255 insertions, 0 deletions
diff --git a/openembedded/kselftest-cpu-hotplug.yaml b/openembedded/kselftest-cpu-hotplug.yaml
new file mode 100644
index 0000000..6891b4f
--- /dev/null
+++ b/openembedded/kselftest-cpu-hotplug.yaml
@@ -0,0 +1,37 @@
+metadata:
+ name: kselftest-cpu-hotplug
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'make -C cpu-hotplug'
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-runner.sh cpu-hotplug ./kselftest/cpu-hotplug/on-off-test.sh'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_-]+):\\s\\[(?P<result>PASS|FAIL|SKIP)\\]"
+ fixupdict:
+ FAIL: fail
+ PASS: pass
+ SKIP: skip
diff --git a/openembedded/kselftest-efivarfs.yaml b/openembedded/kselftest-efivarfs.yaml
new file mode 100644
index 0000000..ee8cf06
--- /dev/null
+++ b/openembedded/kselftest-efivarfs.yaml
@@ -0,0 +1,39 @@
+metadata:
+ name: kselftest-efivarfs
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'make -C efivarfs'
+
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-runner.sh efivarfs ./kselftest/efivarfs/efivarfs.sh'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_-]+):\\s\\[(?P<result>PASS|FAIL|SKIP)\\]"
+ fixupdict:
+ FAIL: fail
+ PASS: pass
+ SKIP: skip
+
diff --git a/openembedded/kselftest-memory-hotplug.yaml b/openembedded/kselftest-memory-hotplug.yaml
new file mode 100644
index 0000000..c9ba063
--- /dev/null
+++ b/openembedded/kselftest-memory-hotplug.yaml
@@ -0,0 +1,38 @@
+metadata:
+ name: kselftest-memory-hotplug
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'make -C memory-hotplug'
+
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-runner.sh memory-hotplug ./kselftest/memory-hotplug/on-off-test.sh'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_-]+):\\s\\[(?P<result>PASS|FAIL|SKIP)\\]"
+ fixupdict:
+ FAIL: fail
+ PASS: pass
+ SKIP: skip
diff --git a/openembedded/kselftest-mqueue.yaml b/openembedded/kselftest-mqueue.yaml
new file mode 100644
index 0000000..e77c604
--- /dev/null
+++ b/openembedded/kselftest-mqueue.yaml
@@ -0,0 +1,36 @@
+metadata:
+ name: kselftest-mqueue
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-mqueue.sh'
+
+parse:
+ pattern: "^(?P<test_case_id>[A-Za-z0-9_>=/, ]+):[\\s]+(?P<result>PASS|FAIL)"
+ fixupdict:
+ PASS: pass
+ FAIL: fail
+
diff --git a/openembedded/kselftest-net.yaml b/openembedded/kselftest-net.yaml
new file mode 100644
index 0000000..fd5ccdc
--- /dev/null
+++ b/openembedded/kselftest-net.yaml
@@ -0,0 +1,33 @@
+metadata:
+ name: kselftest-net
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'make -C net'
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-net.sh'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_]+):\\s(?P<result>pass|fail)"
diff --git a/openembedded/kselftest-ptrace.yaml b/openembedded/kselftest-ptrace.yaml
new file mode 100644
index 0000000..3c326bb
--- /dev/null
+++ b/openembedded/kselftest-ptrace.yaml
@@ -0,0 +1,34 @@
+metadata:
+ name: kselftest-ptrace
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'sed -i "1s/^/CFLAGS = -DPAGE_SIZE=4096\n/" ptrace/Makefile'
+ - 'make -C ptrace'
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './kselftest/ptrace/peeksiginfo && echo "peeksiginfo selftests: pass" || echo "peeksiginfo selftests: fail"'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_ ]+):\\s(?P<result>pass|fail)"
diff --git a/openembedded/kselftest-vm.yaml b/openembedded/kselftest-vm.yaml
new file mode 100644
index 0000000..d19255b
--- /dev/null
+++ b/openembedded/kselftest-vm.yaml
@@ -0,0 +1,38 @@
+metadata:
+ name: kselftest-vm
+ format: "Lava-Test-Shell Test Definition 1.0"
+ description:
+ "These test code were came from kernel source KERNEL_SRC/tools/testing/selftests/
+ For running this test, git is required in the rootfs"
+ maintainer:
+ - arthur.she@linaro.org
+ os:
+ - openembedded
+ devices:
+ - arndale
+ - beaglebone-black
+ - rtsm_fvp_base-aemv8a
+ scope:
+ - functional
+
+install:
+ git-repos:
+ - http://git.linaro.org/qa/kselftest.git
+ steps:
+ - 'cd kselftest'
+ - 'git checkout $BRANCH'
+ - 'make -C vm'
+params:
+ BRANCH: master
+
+run:
+ steps:
+ - './common/scripts/kselftest-runner.sh vm ./kselftest/vm/run_vmtests'
+
+parse:
+ pattern: "^(?P<test_case_id>[a-z_-]+):\\s\\[(?P<result>PASS|FAIL|SKIP)\\]"
+ fixupdict:
+ FAIL: fail
+ PASS: pass
+ SKIP: skip
+