aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2013-04-30 14:20:49 -0500
committerTom Gall <tom.gall@linaro.org>2013-05-24 15:51:21 -0500
commite27260ee0c9c23b2933cfd843e540aecde7fac1e (patch)
treec46081c66f48d78fdf7f8b1382cc1817291d5fdd
parent04621a44f8b7f5cc2d2af1abe9086c16ebf468e3 (diff)
chromium-24.0.1312.52.bb: Initial fix to support aarch64 buildaarch64
Add aarch64 dir with initial config options for chromium on aarch64 and modify chromium-24.0.1312.52.bb to build.
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/aarch64/include.gypi9
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/aarch64/oe-defaults.gypi15
-rw-r--r--recipes-browser/chromium/chromium_24.0.1312.52.bb1
3 files changed, 25 insertions, 0 deletions
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/include.gypi b/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/include.gypi
new file mode 100644
index 0000000..f91d3a7
--- /dev/null
+++ b/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/include.gypi
@@ -0,0 +1,9 @@
+{
+ 'variables': {
+ # Configure for armv8 compilation
+ 'target_arch': 'aarch64',
+ 'armv8': 1,
+ 'arm_thumb': 0,
+ 'arm_neon': 0,
+ },
+}
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/oe-defaults.gypi b/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/oe-defaults.gypi
new file mode 100644
index 0000000..27e1cfe
--- /dev/null
+++ b/recipes-browser/chromium/chromium-24.0.1312.52/aarch64/oe-defaults.gypi
@@ -0,0 +1,15 @@
+{
+ 'variables': {
+ 'use_system_bzip2': 1,
+ 'disable_nacl': 1,
+ 'proprietary_codecs': 1,
+ 'v8_use_snapshot': 1,
+ 'use_system_ffmpeg': 0,
+ 'linux_use_tcmalloc': 0,
+ 'linux_link_kerberos': 0,
+ 'use_kerberos': 0,
+ 'use_cups': 0,
+ 'use_gnome_keyring': 0,
+ 'linux_link_gnome_keyring': 0
+ },
+}
diff --git a/recipes-browser/chromium/chromium_24.0.1312.52.bb b/recipes-browser/chromium/chromium_24.0.1312.52.bb
index a9a2d28..0754724 100644
--- a/recipes-browser/chromium/chromium_24.0.1312.52.bb
+++ b/recipes-browser/chromium/chromium_24.0.1312.52.bb
@@ -22,6 +22,7 @@ COMPATIBLE_MACHINE_i586 = "(.*)"
COMPATIBLE_MACHINE_x86-64 = "(.*)"
COMPATIBLE_MACHINE_armv6 = "(.*)"
COMPATIBLE_MACHINE_armv7a = "(.*)"
+COMPATIBLE_MACHINE_genericarmv8 = "(.*)"
SRC_URI[md5sum] = "ed027b16b20e673af6dcf1831a6d8652"
SRC_URI[sha256sum] = "f30df8b0f4c999185bb11d873f0caa5d8bc581eb4f37ce0fe85fb7900a01d711"