aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Carikli <denis@eukrea.com>2012-05-18 17:09:01 +0200
committerEric Bénard <eric@eukrea.com>2012-05-18 17:47:46 +0200
commit1066d996d9398dabdadfbf7dc465d51bba843ab6 (patch)
tree24a2101f612bf2248b483913917ad09cf10f7af5
parentc47f59df2e723495679c751cbdf6a8c6adec4b6a (diff)
chromium: fix missing include and Werror issues with newer gcc
Without that fix chromium will fail to compile whith the master branch of openembedded-core with undefined references. It would then fails with Werror issues. Signed-off-by: Denis Carikli <denis@eukrea.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes-browser/chromium/chromium/memset.patch13
-rw-r--r--recipes-browser/chromium/chromium/unistd.patch51
-rw-r--r--recipes-browser/chromium/chromium_19.0.1049.3.bb6
3 files changed, 69 insertions, 1 deletions
diff --git a/recipes-browser/chromium/chromium/memset.patch b/recipes-browser/chromium/chromium/memset.patch
new file mode 100644
index 0000000..491002a
--- /dev/null
+++ b/recipes-browser/chromium/chromium/memset.patch
@@ -0,0 +1,13 @@
+Index: chromium-19.0.1049.3/skia/skia.gyp
+===================================================================
+--- chromium-19.0.1049.3.orig/skia/skia.gyp 2012-05-14 17:15:13.906097364 +0200
++++ chromium-19.0.1049.3/skia/skia.gyp 2012-05-14 17:15:50.082099369 +0200
+@@ -1091,7 +1091,7 @@
+ '../third_party/skia/src/opts/opts_check_arm.cpp',
+ ],
+ }],
+- [ 'armv7 == 1 and arm_neon == 0', {
++ [ 'arm_neon == 0', {
+ 'sources': [
+ '../third_party/skia/src/opts/memset.arm.S',
+ ],
diff --git a/recipes-browser/chromium/chromium/unistd.patch b/recipes-browser/chromium/chromium/unistd.patch
new file mode 100644
index 0000000..5e33300
--- /dev/null
+++ b/recipes-browser/chromium/chromium/unistd.patch
@@ -0,0 +1,51 @@
+Index: chromium-19.0.1049.3/ipc/ipc_channel.h
+===================================================================
+--- chromium-19.0.1049.3.orig/ipc/ipc_channel.h 2012-02-23 22:13:19.000000000 +0100
++++ chromium-19.0.1049.3/ipc/ipc_channel.h 2012-05-14 16:00:42.473854656 +0200
+@@ -6,6 +6,8 @@
+ #define IPC_IPC_CHANNEL_H_
+ #pragma once
+
++#include <unistd.h>
++
+ #include "base/compiler_specific.h"
+ #include "ipc/ipc_channel_handle.h"
+ #include "ipc/ipc_message.h"
+Index: chromium-19.0.1049.3/base/message_pump_libevent.cc
+===================================================================
+--- chromium-19.0.1049.3.orig/base/message_pump_libevent.cc 2012-02-23 22:13:19.000000000 +0100
++++ chromium-19.0.1049.3/base/message_pump_libevent.cc 2012-05-14 16:00:42.485854655 +0200
+@@ -6,6 +6,7 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#include <unistd.h>
+
+ #include "base/auto_reset.h"
+ #include "base/compiler_specific.h"
+Index: chromium-19.0.1049.3/chrome/browser/policy/policy_path_parser_linux.cc
+===================================================================
+--- chromium-19.0.1049.3.orig/chrome/browser/policy/policy_path_parser_linux.cc 2012-02-23 22:13:36.000000000 +0100
++++ chromium-19.0.1049.3/chrome/browser/policy/policy_path_parser_linux.cc 2012-05-14 16:00:42.485854655 +0200
+@@ -3,6 +3,7 @@
+ // found in the LICENSE file.
+
+ #include <pwd.h>
++#include <unistd.h>
+
+ #include "chrome/browser/policy/policy_path_parser.h"
+
+Index: chromium-19.0.1049.3/ipc/ipc_platform_file.cc
+===================================================================
+--- chromium-19.0.1049.3.orig/ipc/ipc_platform_file.cc 2012-05-14 16:07:55.493878160 +0200
++++ chromium-19.0.1049.3/ipc/ipc_platform_file.cc 2012-05-14 16:08:01.713878495 +0200
+@@ -4,9 +4,7 @@
+
+ #include "ipc/ipc_platform_file.h"
+
+-#if defined(OS_ANDROID)
+ #include <unistd.h>
+-#endif
+
+ namespace IPC {
+
diff --git a/recipes-browser/chromium/chromium_19.0.1049.3.bb b/recipes-browser/chromium/chromium_19.0.1049.3.bb
index d927cc2..da928d7 100644
--- a/recipes-browser/chromium/chromium_19.0.1049.3.bb
+++ b/recipes-browser/chromium/chromium_19.0.1049.3.bb
@@ -5,8 +5,12 @@ DEPENDS = "xextproto cairo nss gtk+-native zlib-native libav libxi libgnome-keyr
SRC_URI = "http://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.bz2 \
file://include.gypi \
+ file://unistd.patch \
+ file://memset.patch \
"
+PR = "r1"
+
SRC_URI[md5sum] = "0cdd94b2be21180af93f719e9a9a2883"
SRC_URI[sha256sum] = "3bdce0bd8381cd699014e7ec72ab02c7d8444ba511c27afff76bf015361c4021"
@@ -53,7 +57,7 @@ EXTRA_OEMAKE = "-r ${PARALLEL_MAKE} LDFLAGS.host=-L${STAGING_LIBDIR_NATIVE} V=1
TARGET_CFLAGS += "-I${STAGING_INCDIR}/mozilla/nss -I${STAGING_INCDIR}/dst"
TARGET_CXXFLAGS += "-I${STAGING_INCDIR}/mozilla/nss -I${STAGING_INCDIR}/dst"
-TARGET_CC_ARCH += " -Wno-error=deprecated-declarations"
+TARGET_CC_ARCH += " -Wno-error=deprecated-declarations -Wno-error=narrowing -Wno-error=c++0x-compat"
do_compile_prepend() {
export CROSSTOOL=${TARGET_PREFIX}