aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVenture Research <tech@ventureresearch.com>2013-01-24 02:40:48 -0600
committerEric Bénard <eric@eukrea.com>2013-02-05 13:49:49 +0100
commit242ad3ce45df0e359e705639f1771925c5c3fe80 (patch)
tree5131c2e07569be0716bca36ff21bb842b9d06bc2
parentb1462b8008e6cc8078406d34e89eef2076f56804 (diff)
ninja-native: adding initial ninja build support for chromium
Signed-off-by: Venture Research <tech@ventureresearch.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes-devtools/ninja/ninja-native_1.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/ninja/ninja-native_1.1.0.bb b/recipes-devtools/ninja/ninja-native_1.1.0.bb
new file mode 100644
index 0000000..c3235fd
--- /dev/null
+++ b/recipes-devtools/ninja/ninja-native_1.1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Ninja is a small build system with a focus on speed."
+LICENSE = "Apache-2"
+
+inherit native
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+SRCREV="2c953d1501de5195e2485185fa24a2ebfd76bbb5"
+
+SRC_URI = "git://github.com/martine/ninja.git"
+
+S="${WORKDIR}/git"
+
+do_compile() {
+ python ${S}/bootstrap.py
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}