aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-03-26 13:11:29 +0200
committerEric BĂ©nard <eric@eukrea.com>2013-04-29 09:03:36 +0200
commit42c0fc5a37de640a4036d80ca0ebb89882a8fb01 (patch)
tree4002c7d6d1f31816662ead5f75e8cd27aef2a124
parent9c8ad5491b96587fb635e9813299d2e668d4a616 (diff)
nss: change shebang line for smime script
This patch fixes the shebang line of the smime script and also adds a 'perl' RDEPENDS for the main package since smime needs perl to run. Also, this patch fixes some do_rootfs failures when using RPM backend because RPM automatically scans the files and, if perl scripts are found, adds dependency on the file found in the shebang line (i.e. /usr/local/bin/perl). Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
-rw-r--r--recipes-support/nss/nss_3.13.3.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-support/nss/nss_3.13.3.bb b/recipes-support/nss/nss_3.13.3.bb
index 59c16e8..fbab6ee 100644
--- a/recipes-support/nss/nss_3.13.3.bb
+++ b/recipes-support/nss/nss_3.13.3.bb
@@ -105,7 +105,10 @@ do_install() {
sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/nss.pc
sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/nss.pc
sed -i s:OEEXECPREFIX:${exec_prefix}:g ${D}${libdir}/pkgconfig/nss.pc
+
+ sed -i s:/usr/local/bin/perl:${bindir}/perl:g ${D}${bindir}/smime
}
FILES_SOLIBSDEV := ""
FILES_${PN} += "${base_libdir}/lib*${SOLIBSDEV} ${libdir}/lib*${SOLIBSDEV}"
+RDEPENDS_${PN} += "perl"