summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a4b75a..381cbcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,4 +32,24 @@ AM_PROG_AS
AC_PROG_CC
AC_PROG_LIBTOOL
+case $host in
+aarch64*-*-*)
+ arch=aarch64
+ ;;
+arm*-*-*)
+ arch=aarch32
+ ;;
+x86_64-*-*-*)
+ arch=x86_64
+ ;;
+*)
+ arch=generic
+ ;;
+esac
+
+AM_CONDITIONAL([HOST_AARCH32], [test x$arch = xaarch32])
+AM_CONDITIONAL([HOST_AARCH64], [test x$arch = xaarch64])
+AM_CONDITIONAL([HOST_X86_64], [test x$arch = xx86_64])
+AM_CONDITIONAL([HOST_GENERIC], [test x$arch = xgeneric])
+
AC_OUTPUT