aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAbdellatif El Khlifi <abdellatif.elkhlifi@arm.com>2020-06-23 21:00:48 +0100
committersudipto paul <sudipto.paul@arm.com>2020-07-28 12:13:00 +0100
commit080371d1b4536a68b8966e216be5b68d4cda6dce (patch)
tree4af8a3d843a07667ef6844811f506b6015c14262
parent6f3a6e65ef46a10270f5f84e04c99a48ab20f38b (diff)
arm-image/core: configuring the image for corstone700 machines
Defining rootfs content and enabling WIC mechanism for the corstone700 machines. The WIC contains the RAM part of the boot-firmware, TF-A, u-boot, DTB, kernel and rootfs. The bootloaders dependencies are defined by the machine (bootloaders: boot-firmware, TF-A, u-boot). Change-Id: I1ee88c483595d914b958d1001f2e2e0dd8f2d8f1 Signed-off-by: Abdellatif El Khlifi <abdellatif.elkhlifi@arm.com>
-rw-r--r--recipes-core/documentation/corstone700.md13
-rw-r--r--recipes-core/images/arm-reference-corstone700-image.inc21
-rw-r--r--recipes-core/images/arm-reference-image.bb1
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/documentation/corstone700.md b/recipes-core/documentation/corstone700.md
new file mode 100644
index 0000000..2e11886
--- /dev/null
+++ b/recipes-core/documentation/corstone700.md
@@ -0,0 +1,13 @@
+# Corstone-700 image support in meta-arm-image layer
+
+## Image recipe
+
+The image allowing to build the software stack is arm-reference-image
+
+Image settings specific to Corstone-700 are specified under
+
+arm-reference-corstone700-image.inc
+
+## Distro
+
+Corstone-700 supports poky-tiny distro
diff --git a/recipes-core/images/arm-reference-corstone700-image.inc b/recipes-core/images/arm-reference-corstone700-image.inc
new file mode 100644
index 0000000..c842b08
--- /dev/null
+++ b/recipes-core/images/arm-reference-corstone700-image.inc
@@ -0,0 +1,21 @@
+inherit wic_nopt
+inherit cramfs-xip
+inherit u-bootimg
+inherit image-buildinfo
+
+IMAGE_FEATURES += "debug-tweaks"
+
+IMAGE_FSTYPES += "wic wic.nopt cramfs-xip cpio.gz.u-bootimg"
+
+IMAGE_INSTALL += "packagegroup-core-boot"
+
+# deleting the /usr/lib/opkg/alternatives folder
+# because we do not need alternative commands to what
+# busybox offers. This saves around 1MB flash
+remove_alternative_files () {
+ rm -rf ${IMAGE_ROOTFS}/usr/lib/opkg
+}
+ROOTFS_POSTPROCESS_COMMAND += "remove_alternative_files;"
+
+#package management is not supported in corstone700
+IMAGE_FEATURES_remove = "package-management" \ No newline at end of file
diff --git a/recipes-core/images/arm-reference-image.bb b/recipes-core/images/arm-reference-image.bb
index aaa7c53..9e482a4 100644
--- a/recipes-core/images/arm-reference-image.bb
+++ b/recipes-core/images/arm-reference-image.bb
@@ -5,5 +5,6 @@ LICENSE = "MIT"
inherit core-image
MACHINE_IMAGE_REQUIRE ?= ""
+MACHINE_IMAGE_REQUIRE_corstone700 = "arm-reference-corstone700-image.inc"
require ${MACHINE_IMAGE_REQUIRE}