aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-core/documentation/corstone700.md13
-rw-r--r--recipes-core/images/arm-reference-corstone700-image.inc21
-rw-r--r--recipes-core/images/arm-reference-image.bb1
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/documentation/corstone700.md b/recipes-core/documentation/corstone700.md
new file mode 100644
index 0000000..2e11886
--- /dev/null
+++ b/recipes-core/documentation/corstone700.md
@@ -0,0 +1,13 @@
+# Corstone-700 image support in meta-arm-image layer
+
+## Image recipe
+
+The image allowing to build the software stack is arm-reference-image
+
+Image settings specific to Corstone-700 are specified under
+
+arm-reference-corstone700-image.inc
+
+## Distro
+
+Corstone-700 supports poky-tiny distro
diff --git a/recipes-core/images/arm-reference-corstone700-image.inc b/recipes-core/images/arm-reference-corstone700-image.inc
new file mode 100644
index 0000000..c842b08
--- /dev/null
+++ b/recipes-core/images/arm-reference-corstone700-image.inc
@@ -0,0 +1,21 @@
+inherit wic_nopt
+inherit cramfs-xip
+inherit u-bootimg
+inherit image-buildinfo
+
+IMAGE_FEATURES += "debug-tweaks"
+
+IMAGE_FSTYPES += "wic wic.nopt cramfs-xip cpio.gz.u-bootimg"
+
+IMAGE_INSTALL += "packagegroup-core-boot"
+
+# deleting the /usr/lib/opkg/alternatives folder
+# because we do not need alternative commands to what
+# busybox offers. This saves around 1MB flash
+remove_alternative_files () {
+ rm -rf ${IMAGE_ROOTFS}/usr/lib/opkg
+}
+ROOTFS_POSTPROCESS_COMMAND += "remove_alternative_files;"
+
+#package management is not supported in corstone700
+IMAGE_FEATURES_remove = "package-management" \ No newline at end of file
diff --git a/recipes-core/images/arm-reference-image.bb b/recipes-core/images/arm-reference-image.bb
index aaa7c53..9e482a4 100644
--- a/recipes-core/images/arm-reference-image.bb
+++ b/recipes-core/images/arm-reference-image.bb
@@ -5,5 +5,6 @@ LICENSE = "MIT"
inherit core-image
MACHINE_IMAGE_REQUIRE ?= ""
+MACHINE_IMAGE_REQUIRE_corstone700 = "arm-reference-corstone700-image.inc"
require ${MACHINE_IMAGE_REQUIRE}