aboutsummaryrefslogtreecommitdiff
path: root/contrib/native/client/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Gozhiy <anton5813@gmail.com>2019-03-15 13:02:23 +0200
committerSorabh Hamirwasia <sorabh@apache.org>2019-03-15 10:13:54 -0700
commita72f1700a8d260a2f92ba8955c77df6428feb919 (patch)
tree23f7ebbbc36c5811af9a7ef8bc0fa92ac7e01bd0 /contrib/native/client/CMakeLists.txt
parentd69af973d1b91f71dd6314d01dd9399b1f7b9016 (diff)
DRILL-7105: Error while building the Drill native client
Added a compiler option in CMakeLists.txt to support the ISO C++ 2011 standard. Also, changed the CMake min version to 3.1.3 to match the min version specified in protobuf. closes #1697
Diffstat (limited to 'contrib/native/client/CMakeLists.txt')
-rw-r--r--contrib/native/client/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/contrib/native/client/CMakeLists.txt b/contrib/native/client/CMakeLists.txt
index f434c4102..02834b955 100644
--- a/contrib/native/client/CMakeLists.txt
+++ b/contrib/native/client/CMakeLists.txt
@@ -15,7 +15,10 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-cmake_minimum_required(VERSION 2.6)
+cmake_minimum_required(VERSION 3.1.3)
+
+set (CMAKE_CXX_STANDARD 11)
+set (CMAKE_CXX_STANDARD_REQUIRED ON)
project(drillclient)
cmake_policy(SET CMP0043 NEW)